Resolved
US - Stability issue

Started
December 09, 2022 at 4:00 PM
Status
Resolved after about 3 hours

Impact

Degraded performance
Affected
US
API requests
  • Resolved

    We just resolved the issue!

  • Investigating

    We are currently experiencing scalability stability issue. We apologise for any inconvenience and are working to resolve the issue as quickly as possible.